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1. Introduction  

The use of geographic information in decision-making tends to go unnoticed, but it is actually 

present in many of our daily activities. By unconsciously selecting the route to work, the vacation 

route, going to meet a friend, going to a store using a smartphone and more, decisions are made 

that involve analyzing geographic information without being aware of it.  When this type of 

analysis or decision making is carried out using computers, it is usually done through what is 

known as Geographic Information Systems (GIS).  

According to López Trigal (2015), a GIS is a set of tools made up of hardware, software, data and 

users, which allows us to capture, store, manage and analyze digital information, as well as make 

graphs and maps, and represent alphanumeric data. According to Burrough (1994) a GIS can also 

be seen as a computer model of geographic reality to meet specific information needs, i.e., 

create, share and apply useful information based on data and maps.  

For decades, GIS have been applied to land and natural resource management problems, 

environmental issues, military logistics or in contexts directly linked to Earth sciences, such as 

geography, geology, etc. In addition, GIS is of potential use for other relatively unpublished fields 

and disciplines, particularly in research related with Human and Social Sciences (Del Bosque 

González, Fernández Freire, Martín-Forero Morente, & Pérez Asensio, 2012).  

ArcGIS Desktop (hereafter ArcGIS) is the main component of ESRI's ArcGIS application suite, and 

the software that contains the classic desktop GIS functionalities. ArcGIS is a set of tools that 

allows the visualization and management of geographic information, and also has an extensible 

architecture through which new functionalities can be added (Olaya, 2011). These are the well-

known extensions, among which are Spatial Analyst (raster analysis), 3D Analyst (3D and relief 

analysis) or Geostatistical Analyst (geostatistics).   

The purpose of this technical paper is to introduce basic GIS concepts through the development 

of case studies that involve the entire mapping process. There are literally hundreds of tools in 

ArcGIS, but it is not possible to work with all of them, although you can familiarize yourself with 

them. This document is designed so that, as you progress, you can acquire skills or improve those 

you already have in order to create maps, search for geographic information, and finally publish 

a well edited map.  

www.geogeek.xyz/shop
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In addition, an attempt is made to share this document by all possible means by authorizing the 

copying, remixing, transformation, or partial or total redistribution of the material in any non-

commercial medium or format, but always quoting the corresponding source of this work.   

With no further introduction, we start by expressing our wish that it will be of great use to you. 

2. Geographical terms 

Geographical information in digital formats requires the standardization of criteria and the 

incorporation of minimum parameters that guarantee its quality and also allow interoperability 

between users to optimize its use and exchange, leading to the reuse and democratization of 

information (SENPLADES, 2013). 

The following is a glossary of the most relevant geographical terms that will be used in this 

document. Some terms come from the technical series "Geographic Information Standards" 

published by SENPLADES (2013) in its section "Terminology for Geographic Information", which 

are based on ISO / TS 19104: 2008 Geographic information - Terminology and ISO / TC 211 Multi-

Lingual Glossary of Terms. Note that the terms followed by the letters numbered "A" refer to 

the Annexes of the technical series SENPLADES (2013). 

▪ Band: Each of the parts into which the electromagnetic spectrum is divided to enable the 

sensors to capture the electromagnetic radiation. The radiation data (numerical values) 

captured for each defined band are usually organized as raster files (Moreno Jiménez, 

2008). 

▪ Layer: Basic unit of geographic information that can be requested as a map from a server 

[ISO 19128:2005]. Conceptually, a layer is a portion or stratum of geographic space in a 

particular area, and could be considered the equivalent of an element of the legend of the 

map (SENPLADES, 2013). 

▪ Coordinate: Measured value on the earth's surface that serves to determine the position 

of any point on it and, consequently, with respect to the position of any other place. To 

determine these values imaginary lines, perpendicular to each other, are used. These are 

termed parallels and meridians, whose intersection defines the position of the point in the 

coordinate system (López Trigal, 2015). 

▪ Datum: Parameter or set of parameters that define the position (A.282) of the origin, scale 

and orientation of a coordinate system [ISO 19111:2007]. 
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▪ Vertical datum: Datum describing the relationship of height related to gravity or depth with 

the Earth. NOTE: In most cases, the vertical datum is related to the mean sea level. The 

geodesic heights are treated in relation to a three-dimensional ellipsoidal coordinate 

system that refers to a geodetic datum [ISO 19111:2007]. 

▪ Ellipsoid: Surface formed by the rotation of an ellipse around a main axis. NOTE: In this 

international standard, the ellipsoids are always oblong, which means that the axis of 

rotation is always the minor axis [ISO 19111:2007]. 

▪ Scale: Relationship between the magnitudes of the elements represented on the map and 

those that they have in reality. It defines the reduction to which the earth's surface must 

be submitted to be able to represent it in a document or on a map, whose size is much 

smaller. The representation of the scale on a map can be graphical or numerical (López 

Trigal, 2015). 

▪ Geopositioning: Retrieving the geographic position of an object [ISO/TS 19130:2010]. 

▪ Georeferencing: Operation of obtaining and assigning geographical coordinates to 

information (usually a layer) that lacks it. Usually applied to place Earth images or events 

associated with postal addresses (Moreno Jiménez, 2008). 

▪ Image: Raster type coverage whose attribute values are a numeric representation of a 

physical parameter [ISO 19115-2:2009].  

▪ Latitude:  Usually represented by the greek letter φ (capital letter fi), latitude is the angle 

formed from the center of the Earth on the meridian plane by the normal to the ellipsoid 

at the point considered and the plane of the equator. All points on the Earth's surface with 

equal latitude define the parallel lines. The measure is expressed in sexagesimal notation 

starting from the equator, positive towards the north (0° to 90°) and negative towards the 

south (0° to -90°) (Del Bosque González et al. 2012). 

▪ Legend: Application of a classification (A.52) in a specific area using a defined map scale 

and a specific set of data [ISO 19144-1:2009]. 

▪ Longitude: Usually represented by the greek letter λ (lambda), longitude is the dihedral 

angle, formed from the center of the Earth on the plane of the equator, between the 

meridian containing the point and the meridian taken as the origin. The plane of the 

equator is that which passes through the center of the Earth and is perpendicular to the 

axis of rotation. The meridians are lines formed by all points of equal length, and represent 

the intersection of the Earth's surface with planes perpendicular to the plane of the equator 

and containing the axis of rotation (Del Bosque González et al. 2012). 

▪ Digital terrain model and digital elevation model:  A digital terrain model is a spatial 

representation of a quantitative and continuous variable, such as temperature, 

www.geogeek.xyz/shop

Exercises available in: https://geogeek.xyz/product/exercises-fundamentals-of-gis
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elevation, or atmospheric pressure. In particular, when the variable to be represented 

is the elevation of the terrain, it is called the Digital Elevation Model or DEM. Therefore, 

a digital elevation model is a numerical data structure that represents the spatial 

distribution of the altitude of the terrain surface (Mancebo, Ortega, Martín, & Valentín, 

2008). 

▪ Slope: Relation of elevation change with respect to the length of the curve [ISO 

19133:2005]. 

▪ Cartographic projection: Geometric operation that allows the curved surface of the earth 

(three-dimensional) to be represented on a flat (two-dimensional) surface. This procedure 

is used to transform the angular coordinates with which the location of the geographic 

objects is determined on the terrestrial globe into plane coordinates that allow the 

cartographic representation on a surface of two dimensions (López Trigal, 2015). 

▪ Remote sensing: In a broad sense it can be defined as the acquisition of information about 

an object at a distance, that is, without there being material contact between the observed 

object or system and the observer (Sobrino, 2000). 

3. Data models 

It might seem obvious, but before working with GIS data, it must be in digital format. Almost all 

the elements on the Earth's surface can be encoded so that a computer can understand them, 

and, depending on the type of information, one data model or another can be used. What is not 

so obvious is how to represent the real world in a digital medium (ESRI, 2010). 

Despite the heterogeneity of geographic information, there are two basic approaches to simplify 

and model space, so that it can be stored and manipulated in a computer system, giving rise to 

two data models: the vector model, usually used to treat discrete geographic phenomena 

(communications routes, urban fabric, plant cover, etc.), and the raster model, which is generally 

used to represent continuous phenomena. Both systems are complementary and coexist within 

GIS, although each of them is more or less appropriate for studying a specific type of information 

(Del Bosque González at al. 2012).  

3.1. Vector model 

The vector data model is based on the assumption that the Earth's surface is composed of 

discrete objects such as trees, rivers, lagoons, etc. (ESRI, 2010). In this model, there are no 

fundamental units that divide the collected area, but, rather, the variability and characteristics 
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of this area are collected by means of geometric entities. For each geometric entity the 

characteristics are constant. The form of these entities is explicitly codified, because it models 

the geographic space through a series of primitive geometrics containing the most outstanding 

elements of that space. These primitives are of three types: points, lines and polygons (Olaya, 

2014).  

3.2. Raster model 

The raster structure is based on a matrix of cells represented in rows and columns. Each cell can 

store information about a given variable (precipitation, temperature, relative humidity, solar 

radiation, radiance, reflectivity, etc.).  

The raster model does not explicitly collect the coordinates of each cell, but, rather, the values 

of each cell. It is not necessary to accompany these values with a specific spatial location, since 

they refer to a particular element of the mesh, which represents a fixed and regular structure. 

But it is necessary to place this grid in space so that the coordinates of each cell can be calculated 

(Olaya, 2014). 

4. ArcMap main window 

ArcGIS contains a set of applications to solve real-world geographic problems through a 

sequence of spatial operations. ArcMap is the central application that allows you to perform the 

usual tasks and advanced analysis, as well as show the results by means of attractive printed or 

digital maps. 

The structure of the main ArcMap window (Figure 1)  provides a Menu Bar, below which are the 

toolbars that can be customized from the "Customize" menu. On the left-hand side is the Table 

of Contents, where all the participating layers are located. Panels: Results, ArcToolbox, Catalog, 

Search, etc. can be found vertically on the right and can be activated independently. To explore 

the geographic information, it is possible to use Data View, and Layout View can be used to 

design the map before its publication. 

www.geogeek.xyz/shop
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Figure 1. Overview of the ArcMap application 

The Tools toolbar contains the most commonly used functions in ArcMap. The main functions 

of each tool are described in Figure 2. 

 

 Figure 2. Tools toolbar 

- The Zoom In/Zoom Out tools allow you to zoom in or out within the Data View. You can 

draw a box on the map to see a specific area in greater or less detail. 

- The Pan tool is used to move the map freely up, down, left or right without changing the 

extension and without suffering a change in the working scale. This action is called 

panning.  

- Full Extent allows you to see the total extent of all the participating layers of the active 

map.  

- Fixed Zoom In/Fixed Zoom Out tools have the ability to prevent zooming in or out too 

much and so lose sight of the map, because with each click, you can zoom in or out only 

by a fixed amount.  

- Previous Extent/Next Extent are used to return to a previous zoom-in or zoom-out view. 

It permits you to "undo" the navigation screen, which is very useful when the map view 

has been lost by mistake. 

Table of Contents 

 

Panels 

 

Menu Bar 

 

Data View 

 

Toolbar 

 

Buttons to switch between Data 

View and Layout View 
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- Select Features/Clear Selected Features. The first tool allows entities to be selected 

within a rectangle, polygon, loop, circle or line. Once selected, the entities are 

highlighted in blue. The second tool (Clear Selected Features) removes the selection.  

- Select Elements lets you select, move, or re-size graphics or text on the map. This facility 

is also available on the Draw toolbar. 

- The Identify tool identifies the geographic characteristics of an element by means of a 

click. 

- Measure measures the distance and/or area of a sector within the workspace. This tool 

may appear inactive if, at the beginning of the work with ArcMap, we load a layer with 

no spatial reference system. The reason for this is that the program does not know the 

units of the layer. In this case it is necessary to indicate the coordinate system.  Assuming 

that the spatial reference system of the layer is WGS84 17S (we will see later what this 

means), then the map units are meters. Double click in the Data Frame (in Layers), go 

to the General tab, and click on Map and on Display in the Units section, and indicate 

Meters. 

- Find allows you to search for an entity, place or address. 

- Go To XY allows you to locate a point by means of a coordinate in XY format. 

5. Coordinate systems 

Human beings have always felt a need to represent the Earth's surface and the elements on it, 

as a result of which maps emerged (IGN & UPM-LatinGEO, 2013). Coordinate systems are 

fundamental when working with GIS, although they are often overlooked.  But, while all 

locations are identified using a coordinate system, the same location may have different 

coordinates depending on the coordinate system used by the dataset (ESRI, 2011b). 

To better understand coordinate systems it is necessary to comprehend the following terms: 

projection, ellipsoid, geoid and datum. 

The projection is intended to geometrically represent the Earth's surface, which is curved, on a 

flat surface. But when this process is carried out, deformations inevitably occur and each 

projection generates a different type of distortion. Before drawing up a map, one of the most 

important decisions is to know which projection will be used, because each projection works 

best in a specific place. Projections can distort the shape, area, distance and direction on a map, 

attributes by which they can be categorized into conforms: these projections conserve the 

angles between meridians and parallels, but maintain the shapes. If equivalent, they maintain 

www.geogeek.xyz/shop

Exercises available in: https://geogeek.xyz/product/exercises-fundamentals-of-gis



12 
 

constant surface relationships, and if equidistant, they maintain the relations of distance (Del 

Bosque González et al. 2012).  

An ellipsoid is the geometric figure that best adapts to the real shape of the Earth, and so it is 

the one that best allows a good fitting. Once a theoretical expression for the shape of the Earth 

is available, the next step is to determine the parameters that define it. If a sphere is used, its 

radius must be calculated. If an ellipsoid is taken as a reference form, the minor and major semi-

axes must be measured (Olaya, 2014). In addition, an ellipsoid (also called a spheroid) may be 

defined as a three-dimensional shape created from a two-dimensional ellipse. The ellipse is an 

oval, with a major axis (the longest axis) and a minor axis (the shortest axis). If the ellipse is spun, 

the shape of the spun figure is the spheroid (ESRI, 2015). 

The geoid is defined as the surface of the Earth's gravity field, which is approximately equal to 

the mean sea level. It is perpendicular to the direction of gravitational attraction since the 

Earth's mass is not uniform at all points and the direction of gravity changes. The shape of the 

geoid is irregular (ESRI, 2015). 

Figure 3. Relationship between geoid, topographic surface and ellipsoid fitting. Image Credit: Peter H. Dana, 1994.  

The datum specifies the spheroid that will be used to give the shape to the coordinate system. 

It also directs the spheroid to a series of land control points, ensuring the accuracy of a reference 

point for its intended region or spatial extent (ESRI, 2011b). The datum is generated above the 

selected spheroid and can incorporate local variations in elevation. With the spheroid, the 

rotation of the ellipse creates a totally smooth surface of the whole world. Since reality is not 

properly represented in this way, a local datum may incorporate local variations in elevation 

(ESRI, 2015).  

Put simply, projection is the method used to represent the circular shape of the Earth in a plane, 

and the datum is the set of parameters that is used to do it. 
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Geographic information can be displayed according to a geographic coordinate system or a 

projected coordinate system. The geographic coordinate system indicates a location using the 

longitude and latitude based on a sphere (spheroid). The XY projected coordinate system is 

based on a plane (Hillier, 2011). The most commonly used geodetic reference systems are: 

WGS84, NAD 27, NAD 83, ED50, ETRS89, PSAD56, and SIRGAS. In addition, some coordinate 

systems have certain advantages, such as the ability to quickly measure distances and surfaces. 

6. Georeferencing  

Georeferencing is a technique of spatial positioning by means of which a digital image is assigned 

a reference system based on known coordinates. 

 

Figure 4. Aerial image without georeferencing 

Some raster information is not associated with a reference system, such as maps, scanned 

topographic maps, aerial images, etc. To link an image to a known coordinate system, you must 

perform the georeferencing process, which is explained below. 

In the georeferencing of an aerial image, once the ArcMap application is executed, click on the 

Add Data icon in the Standard bar load the image (Figure 5). 
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Figure 5. Standard Toolbar 

The directory is scanned and the raster file that is to be georeferenced is selected (for the 

present example it is possible to capture and / or save the image of Figure 4 in tif, jpg, png 

format), ignoring the unknown spatial reference message. In topographic maps, several control 

points can generally be identified through the coordinates shown on the X and Y axes. In this 

example, two known points P1 (UTMX: 691194; UTMY: 9532767) and P2 (UTMX: 691895; UTMY: 

9532347) are used. 

Activate the Georeferencing toolbar (Figure 6): If not found use the Customize > Toolbars menu.  

 

Figure 6. Georeferencing toolbar 

Make sure that the added image (georeference_image.jpg) is inside the bar. If you cannot see 

the image in the current screen view, click Georeferencing > Fit To Display. 

Now click on the Add Control Points icon; this tool allows you to adjust the image spatially by 

means of known points. The first step is to mark a known point on the image (P1). Once the 

cursor is positioned, it turns green, then right-click and select Input X and Y to enter the XY 

coordinates (Figure 7). The process is repeated for the second point (P2) and for the other points 

that need to be added.  

To finish with georeferencing after acceptable adjustment of the control points, go to 

Georeferencing > Update Georeferencing. This will create auxiliary files to the current image 

containing the transformations made. If Rectify is selected, the changes are saved and a new 

georreferenced image is created.  

 

Figure 7. Enter XY coordinates 
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If you do not have the coordinates of the control points on the ground, but you do have 

reference elements such as roads, buildings, trees, etc., it is still possible that these elements 

can be used for georeferencing. For example, the georeferencing of an image based on a track 

shapefile is done by identifying a common point (intersection) in both layers (call up Zoom To 

Layer with right click on the track layer, then call up the Fit To Display image from the 

Georreferencing bar). To create a link, first click on the image to mark the starting point (green 

cross in Figure 8a), a second click is marked at the actual point on the terrain (grey cross in Figure 

8a). For the following points, the process is repeated in a similar way. The blue line joining the 

checkpoints means that an associated link has been created between a point in the image and 

the real world (Figure 8b). The adjustment of the two layers is done automatically after each 

point association.  

 

Figure 8. Georeferencing process, (a) initial linking point, (b) linked points 

The number of control points is not strictly reflected in the quality of the result, and the 

important thing is to make an adequate distribution.  Try not to concentrate the control points 

in a single sector (Figure 9b) but distribute them homogeneously within the image (Figure 9a). 

The more points you can apply, the more complicated the transformations (polynomial, spline, 

adjustment or projective) you can use to determine the proper location of the coordinates for 

each cell of the raster image.  

b a 

www.geogeek.xyz/shop

Exercises available in: https://geogeek.xyz/product/exercises-fundamentals-of-gis



16 
 

 

Figure 9. Distribution of control points: (a) homogeneous distribution, and (b) heterogeneous distribution  

7. Generation of vector entities 

7.1. Creating shapefiles 

The ArcCatalog application (open from the Windows Start menu) is used to create new vector 

entities such as points, lines or polygons. On the left-hand side of the window there is a panel 

called Catalog Tree. Right-click on Folder Connections (Figure 10) to select the directories that 

will serve as the location of working files within ArcGIS (it is possible to select an entire hard disk 

drive, to avoid creating excessive connections).  

 

Figure 10. Connecting to a Directory in ArcCatalog 

Once the directories have been connected, a new entity can be created by right-clicking on the 

Contents > New > Shapefile... section or by going to the File > New > Shapefile... menu.  

b a 
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Figure 11. Creation of new shapefile entities 

Set up the fields shown in Figure 11 as follows: 

- Name: Assign a name to the new shapefile; it is recommended not to use special 

characters or spaces. 

- Feature Type: Select the type of layer: point, line or polygon. 

- Spatial Reference: In this section you define the reference system using the Edit button.  

For the present case, the following applies: Projected Coordinate Systems > UTM > WGS 

1984 > Southern Hemisphere > WGS 1984 UTM Zone 17S. The boxes “Coordinates will 

contain M values. Used to store route data” and “Coordinates will contain Z values. Used 

to store 3D data” are left, as they are by default.  

Practice: Create point, line and polygon shapefiles from Table 1; use reference system WGS 1984 

UTM Zone 17S.  

Table 1. List of shapefiles 

Shapefile Type 
buildings Point 
hydrant_points Point 
secure_sites Point 
road_network Line 
water_network Line 
plant_cover Polygon 
lake Polygon 
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7.2. Shapefiles edition 

To create new elements or edit existing ones within a shapefile, return to the ArcMap application 

and add the shapefiles generated as layers using the Add Data icon in the Standard toolbar 

(Figure 2). 

To start editing, activate the Editor toolbar (Figure 12). Go to Editor > Start editing to enable 

editing in the workspace (in shapefile). In the next dialog box that appears, select the layer or 

workspace to edit. In case of warnings, omit them and click continue. The Create Features panel 

(left) then appears with a list of the current layers sorted by their geometry (points, lines and 

polygons), and in Construction Tools select the feature you want to edit. The central idea of 

editing a shapefiles is to map the elements present in an image (to maintain an order, start first 

to work with the points, then with the lines and finally with the polygons). All required changes 

can then be made to the selected shapefile. To finish editing, go to Editor > Stop editing and 

save the modifications. Changes only affect the selected vector entity.  

 

Figure 12. Toolbar Editor 

7.3. Working with points 

To start digitizing the points, select a point layer (e. g. buildings) in the Create Features panel. It 

is advisable to make sure that the Point tool is marked in Construction Tools (lower part). Then 

place the cursor on the center of a house and click to mark a point. The process is repeated until 

all the buildings are digitized (Figure 13). To make it easier to work with small objects, zoom 

tools are used and for large images the panning tool can be used, increasing versatility during 

the process. Besides using the mouse, it is possible to use the arrow keys of the keyboard, which 

allow greater precision in movement. It is recommended that you periodically go to the Editor 

> Save Edits toolbar to save your changes. 
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Figure 13. ArcMap application editing mode 

You can also create new points by entering the XY coordinates. In this case, select a point layer 

(e. g. hydrant_points) in the Create Features panel; do not forget to mark "Point" in 

Construction Tools. Then position yourself anywhere on the map, right click and select Absolute 

X, Y... (Figure 14). A window opens where you can enter the XY values (e. g. X = 691491; Y = 

9532534 for the first point, X = 691735; Y = 9532696 for the second point). The entry is accepted 

by pressing the "Enter" key.  

 

Figure 14. Manually insert points using coordinates 

Coordinates can be entered in different formats such as meters, decimal degrees, MGRS 

(Military Grid Reference System), UTM, etc. To change the format, the Absolute X, Y window 

opens as explained above and click on a pop-up icon in the upper right corner. A list of options 

opens where you can select the format. The UTM format is entered as shown in Figure 15  (e. g. 

secure_sites: 17M 691523 9532468,17M 691684 9532576,17M 691889 9532681,17M 691437 

9532615). Press the "Enter" key to enter each of the required points. Finally, you must save the 

edition using the Editor bar (Editor > Save Edits).  
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Figure 15. Coordinate format available in Absolute X, Y. 

To correct the spatial location of a point, first select the layer to be modified (shapefile) in the 

Create Features panel. Then click on the Editor bar in the symbol (= Edit Tool). To change the 

location of a point or delete it, select the required point with a click (this becomes light blue). It 

is now possible to drag it to a new location (see Figure 16) or delete it by pressing "Delete" on 

the keyboard.  

 

Figure 16. Edit Tool 

7.4. Working with lines  

To digitize lines, select the required layer in the Create Features panel (e. g. road_network). In 

the Construction Tools section, click Line as shown in Figure 17. To draw the line, click on the 

starting point and then follow point to point until a section is completed (e. g. a railway).  To end 

the line, double-click on the last vertex or press the F2 key. The green nodes indicate the number 

of points that have been marked to construct the polyline; the red node is the last marked point. 

The procedure is repeated for all sections of the shapefile (e. g. the entire road network).  

When digitizing lines, it is important to maintain connectivity between elements. For example, 

in the case of the road network, you cannot have sections that do not connect to each other, 
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nor sectors where the connections go beyond the borders of an existing entity. In order to be 

more accurate in editing and avoid errors, Snapping tools (Customize > Toolbars) allow the 

pointer to automatically adjust to the edges, vertices or other nearby geometric elements within 

a given degree of tolerance. 

Practice: For the water_network layer, identify the riverbed in Figure 4, then proceed with 

digitizing in the same way as with the road network.  

 

Figure 17. Line digitizing in ArcMap 

To modify a polyline, select the Edit Tool ( ) icon in the Editor toolbar. Then click on a segment, 

which give it a light blue color. You can now delete the line or move the entire line. If you double-

click on the required segment, all the vertices of the polyline will be shown. Each of the vertices 

can then be moved freely until the desired path is obtained (Figure 18).  

It is recommended to avoid 

placing too many vertices in a 

straight line; it is feasible to 

place only vertices at the end 

points. In the case of a 

curvature, more vertexes are 

needed to fit the shape. To 

delete a vertex, right click on it 

and then select Delete Vertex. To add one or more vertices right click on the polyline segment 

and select Insert Vertex. In some cases, a polyline needs to be divided into two or more parts. 

To do this, select the polyline and with Split Tool ( ), located in the Editor toolbar. The line is 

divided with a click on the required point (which is highlighted in red).   

Figure 18. Modification of polylines 

www.geogeek.xyz/shop

Exercises available in: https://geogeek.xyz/product/exercises-fundamentals-of-gis



22 
 

To delete a line completely, select the line with the Edit Tool and press the "Delete" key. To 

select two or more lines, press the "Shift" key.  

7.5. Working with polygons 

The process of digitizing polygons is similar to that of polylines. In the Create Features panel, 

select the layer (e. g. plant_cover) and choose Polygon in the Construction Tools. To start, mark 

the first vertex with a click and then continue drawing the entire perimeter of the area. To finish, 

double-click or press the "F2" key. You can define several categories (e. g. Figure 4: Grassland, 

crops and forest).  

 

Figure 19. Editing polygons in ArcMap 

In the case of polygons sharing one side, it is necessary to ensure that there are no overlapping 

surfaces or empty spaces in the boundaries of the polygons.  

Gaps or empty spaces are not usually visible 

to the naked eye, but only when there is a 

close approximation to the boundaries of 

the plots. Similarly, areas shared by two or 

more polygons may occur, which is called 

overlap (see Figure 20). These topological 

errors usually occur when no methods for 

maintaining the topological rules were used 

in the edition. The same may occur when 

compiling information from different 

sources or scales.  

Figure 20. Gaps and overlap in polygons 
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There are several tools in ArcMap that allow you to maintain integrity and quality when editing 

spatial information. Two fundamental tools are located in the Editor bar (Cut Polygons Tool and 

Reshape Feature Tool) and another one in the section Construction Tools (Auto Complete 

Polygons) that allow a polygonal layer to be successfully digitized, significantly reducing the 

amount of errors that are usually generated in this activity.  

When attempting to draw a surface with subdivisions, it is preferable to first create the external 

perimeter and then make the internal division. For example, when building a land use map, it is 

recommended to draw the entire study area and then divide into categories. To carry out this 

process, activate the Edit Tool ( ) in the Editor bar and select the required polygon (the edges 

of the polygon turn light blue). Then click on Cut Polygons Tool ( ) to proceed. To cut the 

polygon, mark the first point outside the polygon and continue drawing a cutting line inside the 

area. The last point must be outside the polygon (see Figure 21). The cut is completed with a 

double click or by pressing the "F2" key.  The process can be repeated as many times as 

necessary until all required divisions of the area are made. It should be emphasized that this tool 

is only activated when one or more polygons are selected.  

 

Figure 21. Cutting polygons in ArcMap 

Editing polygons also requires knowing how to change their shape, especially when certain 

geometric readjustments are required. To do this, select the polygon (with the Edit Tool) and 

then click on the Reshape Features Tool icon ( ) located on the Editor toolbar. An example of 

how to change the shape of the polygon is given in Figure 22. In the first two polygons on the 

left, it is shown how to increase the area of a polygon (in this example: a square). The important 

thing is always to start and finish the readjustment inside the polygon. On the right-hand side, 

the last two polygons show how to reduce the area of a polygon (in this example, to obtain a 

square shape). For the readjustment, you must start and finish outside the polygon. 
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Figure 22. Change shape to a polygon 

If polygons need to be created next to each other, do not draw a border twice, but maintain a 

continuous structure (no overlapping or gaps). To create continuous polygons, go to the Create 

Features panel, in the Construction Tools section check the Auto Complete Polygons ( ) 

option. To start drawing the new continuous polygons, it is not necessary to select the entities. 

The new polygon is drawn with at least two vertices connecting it to its neighbors (Figure 23). 

 

Figure 23. Autocomplete polygons 

Additionally, it is often necessary to merge two or more polygons into a shapefile. To do this, 

select the participating polygons by pressing the "Shift" key during selection. The Merge tool is 

then applied from the Editor toolbar (Editor > Merge). 

Practice: In the plant_cover and lake layers, digitize the polygons, making use of the editing 

tools. When you have finished all the activities involved in digitizing points, lines or polygons, 

finish editing with Stop Editing located in the Editor toolbar (Editor > Stop Editing).  

7.6. Define projection of a layer 

At certain times when loading new layers into ArcMap, a warning message (“The following data 

sources you added are missing spatial reference information. This data can be drawn in ArcMap, 

but cannot be projected”). This is because the added layers do not have a coordinate system, 

probably because, while creating the layers, the spatial reference system was omitted.  

It is recommended not to define a coordinate system if you are not sure it is the correct one. To 

define the coordinate system in a layer (vector or raster) go to the following address:  
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ArcToolbox > Data Management Tools > Projections and Transformations > Define Projection 

In the pop-up window you must configure the parameters described below: 

- Input Dataset or Feature Class: Select the vector or raster layer. 

- Coordinate System: Select the coordinate system (Projected Coordinate Systems > UTM 

> WGS 1984 > Southern Hemisphere > WGS 1984 UTM Zone 17S). 

7.7. Project a layer to another reference system 

The Project tool allows you to project spatial data from one coordinate system to a different 

coordinate system. 

Practice: A layer projected with the coordinate system "WGS 1984 UTM Zone 17S" is required 

to be projected with "Provisional South American Datum UTM Zone 17S". Note that both 

systems have a different datum (WGS84 and PSAD56). Therefore, it is necessary to apply the 

corresponding transformations for each locality. The list of transformations can be found in the 

geographic_transformations.pdf file located in the ArcGIS "C:\Program 

Files\ArcGIS\Desktop10.x\Documentation " installation folder (Figure 24).  

 

Figure 24. Fragment of the “Geographic and Vertical Transformation Tables” document 
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To reproject, open the Project tool (Figure 25) and configure it as below in:  

ArcToolbox > Data Management Tools > Projections and Transformations > Project 

 

Figure 25. Projecting a layer to another coordinate system 

- Input Dataset or Feature Class: Select the layer to be projected. 

- Input Coordinate System: By default, the current layer coordinate system is displayed. 

- Output Dataset or Feature Class: Select the directory or geodatabase where the 

resulting file will be stored. 

- Output Coordinate System: Select the new coordinate system. In this case go to: 

Projected Coordinate Systems > UTM > South America > Provisional South American 

Datum UTM Zone 17S. 

- Geographic Transformation: Select the transformation from the list of the "Geographic 

and Vertical Transformation Tables" document. In this case 

"PSAD_1956_To_WGS_1984_14" because the layer to be projected is located in 

continental Ecuador. You could also select "PSAD_1956_To_WGS_1984_6", but note 

that the accuracy will be lower, see Figure 24.  
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In versions prior to ArcGIS 10.3, the Project tool is usually located in Projections and 

Transformations > Features. To change the coordinate system in a raster file, use the Project 

Raster tool located in Projections and Transformations > Raster.  

8. Tables administration  

Tables are used to store descriptive information. In ArcGIS they are usually linked to a vector 

layer or appear individually. The alphanumeric information forming a table can be stored as an 

integer, decimal number, text or date. The supported table formats are diverse: Geodatabases, 

databases, INFO, dBASE, text files, Microsoft Excel, Access, SQL, etc.  

8.1. Working with tables  

Each shapefile contains an associated table in DBF format. To view the table of a vector file in 

ArcMap right click on a layer and select Open Attribute Table.  

A table is structured in rows and columns. Each row can be considered as an object containing 

values in different fields. A column is restricted to a single data type and is considered as a field. 

You can add as many fields as required to a table. 

Once the table has been opened, a new field can be created by going to Table Options ( ) 

and selecting Add Field (note that no edition is active, if it is active, click on "Stop Editing"). Then 

a dialog box appears where you must specify the new field (see Figure 26). First you must name 

the new field, taking into account that you cannot include spaces or special characters and are 

limited to a length of eight characters in shapefiles and dfb tables. Then, specify the field type 

for which there are several options clarifying which data are allowed within this field (numerical: 

short integer, long integer, float or double; text: text; date: date). Finally, you specify the 

properties of this field ("Field Properties"), where the accuracy (numbers) and/or space (text) is 

limited. 
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Figure 26. Adding fields to a table 

To choose the type of new field, consider the information provided by (Neer, 2005): 

▪ Short Integer, are numbers integers between -32768 y 32767. 

▪ Long Integer, are integer numbers between -2147483648 and 2147483647. 

▪ Float, are fractional numbers between -3.4E38 and 1.2E38. 

▪ Double, are fractional numbers between -2.2E308 and 1.8E308. 

▪ Text, is a text string limited to 255 characters in length. 

▪ Date, are data stored in Universal Time Coordinates (UTC). 

To enter information within each field, you need to be in Edit Mode (Editor > Start Editing). The 

attribute table ("Open Attribute Table") opens and values can be entered directly in cell.  

To add the same information/calculation to one or more rows, right-click on the required 

field (e. g. Type) and select the “Field Calculator” tool. A new dialog box opens where by 

default VB Script from the “Parser” section is enabled (if necessary, switch to Python). In 

the “Fields" section you can find all the fields of the current table, and in the "Type" 

section you can see the type of data (Figure 27).  

 To enter the information, you must type the numbers directly, enclosing the text in quotation 

marks (" "; for example, randomly select one or more buildings and call them "School"; you can 

repeat the process for "Church", "Hospital" or "Housing") in the window at the bottom. 
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Figure 27. Data entry with Field Calculator 

Practice: Add new fields to shapefiles and configure their name, type and properties as shown 

in Table 2. 

Table 2. Structure for creating fields in tables 

Shapefile Name Type Properties 

buildings Type Text Length: 25 

hydrant_points Name Text Length: 25 

secure_sites Name Text Length: 25 

road_network Type 
Length 

Text 
Double 

Length: 25 
Precision: 0, Scale: 0 

water_network Name 
Length 

Text 
Double 

Length: 25 
Precision: 0, Scale: 0 

plant_cover Type 
Area 
Percentage 

Text 
Double 
Double 

Length: 25 
Precision: 0, Scale: 0 
Precision: 0, Scale: 0 

lake Name 
Area 
Perimeter 

Text 
Double 
Double 

Length: 25 
Precision: 0, Scale: 0 
Precision: 0, Scale: 0 

Fill in the table values based on the following information: 

- hydrant_points, in the Name field, call the first point "Main" and the second 

"Secondary".  

- secure_sites, in the Name field, call the first and fourth points "Secure sites" and the 

second and third point "Meeting zone". 

- road_network, in the Type field, name the entities that extend along the coordinate X: 

691723 Y: 9532552 as "Main way", name the segment that extends along coordinate X: 

691394 Y: 9532401 as "Unpaved way”, name as "Path" the segment that extends along 
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the coordinate X: 691570 Y: 9532693, and name as "Street" all remaining segments in 

the urban area. 

- water_network, in the Name field call it "Malacatos River". 

- plant_cover, based on Figure 4 name the polygons in the Type field as "Grassland", 

"Crops" or "Forest", as appropriate. 

- lake, in the Name field, name it "Santa Anilla Lake". 

8.2. Calculation of area, perimeter and length 

To calculate the area, perimeter or length of the different entities, it is necessary to take into 

account the geometry of each layer. First, ensure that the participant layer has a defined 

reference system. It is important to remember that when you work with shapefiles and make 

changes in the geometry, the area, perimeter and length fields are not automatically updated. 

It is necessary to recalculate the current values after each change. 

To start, right-click on the layer and open the attribute table (e. g. lake). Then right-click on the 

header of the required field (e. g. Area) and select the "Calculate Geometry" tool. Finally, select 

the geometric property, coordinate system and units you want to use (see Figure 28; area in 

Acres US).  

Practice: Repeat the process and calculate the area in acre for the plant_cover layer. 

 

Figure 28. Geometry calculations 

The same process as described in the previous paragraph can also be used to calculate the 

perimeter (e. g. in meters) of the layer: you simply have to change from Area to Perimeter in 

the "Property" section. For polyline layers (e. g. road_network and water_network) only the 
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length can be calculated (e. g. in meters) and for point layers only the XY coordinates can be 

calculated. In summary, the "Calculate Geometry" tool allows the geometry to be calculated, 

depending on the nature of each layer.  

8.3. Calculation of XY coordinates 

The Add XY Coordinates tool allows the values of the XY coordinates to be calculated (if the 

layers have the Z coordinate (height), it can also be calculated). To execute, go to the following 

address:  

ArcToolbox > Data Management Tools > Features 

 

Figure 29. Add XY coordinates 

In the "Input Features" section, first select the layer (e. g. buildings) and confirm the selection 

by pressing "OK" (Figure 29). Then the attribute table opens, where it can be seen that two new 

fields have been created. These new fields store the XY coordinates of the point layer. The same 

process can be repeated for all point layers (e. g. secure_sites and hydrant_points).  

8.4. Operations  

The Field Calculator performs simple and complex calculations for both text strings and 

mathematical operations. Note that the modifications affect all records (if none is selected) or 

only the selected records. 

To calculate the percentage of each polygon with respect to the total surface area (e. g. 

plant_cover layer), the value of the total surface area must first be determined. To do this, open 

the attribute table, right click on the field header (Area), select Statistics and in the Sum line you 

will find the total area of all polygons in this layer. Then right click on the header of the created 

field (Percentage), select the "Field Calculator" tool and use the following expression: [Area] * 
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100 / total area value. The expression [Area] in the equation corresponds to the name of the 

field, which can be selected directly by double-clicking on the "Fields" section (Figure 30). 

  

Figure 30. Field Calculator operations 

Equations can contain different mathematical operations (sum, subtraction, division and 

multiplication), including parentheses. Calculations can be developed using VB Script or Python. 

When accessing geoprocessing functions is required (including entity geometry calculation), 

Python is recommended. In addition, this language provides greater opportunities for scripting 

calculations. Further information about the field calculator can be found in "About calculating 

fields", where a comprehensive list of examples is available (Figure 30). 

9. Geoprocessing tools  

GIS tools undoubtedly automate processes that used to take a long time to carry out. In general, 

manual tasks often require a great deal of effort to complete. Geoprocessing is the methodical 

execution of a sequence of operations over geographic data to create new information. The two 

fundamental purposes of these tools are to help with modeling and analysis, and to automate 

GIS tasks (ESRI, 2016b). 
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From this point onwards, the most frequently used tools will be those of ArcToolbox ( ), 

although some of the most common geoprocessing tools can still be accessed from the 

Geoprocessing menu. The use of each tool presents a similar structure: a pop-up window 

requests input and output files, apart from configurable fields depending on the nature of the 

tool.  

9.1. Buffer 

Imagine for a moment that a drop of water falls on a mass of water and generates a shock wave. 

The wave is shifted and the propagation phenomenon can cause positive or negative changes 

from its point of origin. Influence zones are polygons created from an entity at a set distance. 

This spatial analysis allows the affected surface to be identified (e. g. a new factory), influence 

zones (e. g. "opening of a road within a protected area"), those affected by a contaminant (e. g. 

"fertilizers”), and the range of antennas (e. g. telecommunications or weather radar). 

Using the Buffer tool, you can create influence zones for points, lines and polygons. The tool is 

available in the Geoprocessing menu bar or at the following address:  

ArcToolbox > Analysis Tools > Proximity > Buffer 

The "Buffer" pop-up window (Figure 31) can 

be configured in the following way:  

- Input Features: Select the layer of 

points, lines or polygons. 

- Output Features Class: Select the 

directory or geodatabase where the resulting 

entity will be stored. 

- Distance [value or field]: There are two 

options: "Linear unit", which allows you to set 

a fixed value with the respective unit (e. g. 

meters), and "Field", which creates an 

influence zone based on the values of a field 

selected from the attribute table. 

- Method: Specifies the method used to 

create the zone of influence. The "Planar" method uses Euclidean distance (as if 

Figure 31. Buffer tool configuration 
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measured with a ruler in a projected plane), and "Geodesic" takes into account the 

curvature of the earth regardless of the layer coordinate system. Influence zones are 

not influenced by the distortion of a projected coordinate system. 

Figure 32 shows influence zones for three points, one line and two polygons using a linear unit 

of 20 meters and the planar method as a distance.  

 

Figure 32. Influence zones 

9.2. Intersect 

The intersection allows you to search for the area of two or more overlapping layers. The 

Intersect tool calculates the intersection area in a new layer. To use the tool, go to:  

ArcToolbox > Analysis Tools > Overlay > Intersect 

The Intersect tool pop-up window opens.  In the Input Features section, you can add all the 

layers that are going to be searched for intersection areas.  An example of the result can be seen 

in Figure 33. 

 

Figure 33. Intersection area 
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9.3. Clip 

The Clip tool allows you to trim part of an entity based on the perimeter of a polygonal layer 

(Figure 35). The polygonal layer is used to limit the extent of the layers to a specific area. For 

example, if you have a layer of contour lines at country level, you can make a clipping to work 

at province level. The tool is located at the following address:  

ArcToolbox > Analysis Tools > Extract > Clip 

 To configure the tool, proceed as 

follows (Figure 34): 

- Input Features: Select the layer of 

points, lines or polygons to be 

trimmed. 

- Clip Features: Select the polygonal 

layer containing the trimming 

perimeter. 

- Output Features Class: Select the directory or geodatabase where the new cropped 

layer will be saved. 

- XY Tolerance: This is an optional tolerance parameter that establishes the distance that 

a coordinate can be moved in both X and Y. 

 

Figure 35. Trimming of vector entities 

9.4. Merge 

Merge tool can be used to merge two or more entities into a single layer. All merging entities 

must be of the same type (points, lines or polygons). Caution should be exercised because this 

tool does not modify the geometry of the entities, even if there is overlap. The tool is located at 

the following address:  

Figure 34. Clip tool configuration 
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ArcToolbox > Data Management Tools > General > Merge 

In the Merge tool pop-up window, you will find the Input Dataset section where all the layers 

to be merged are selected (remember that they must be of the same geometry). In the Output 

Dataset section, a name and directory are assigned to the resulting layer. In the Field Map 

section, fields of the participating layers are added, renamed or deleted. An example is shown 

in Figure 36, where two layers of separate polygons are located on the left and the merging of 

the two layers into one is shown on the right. 

 

Figure 36. Merging entities  

9.5. Dissolve 

This tool unifies geographic information on the basis of an attribute; in other words, it merges 

information that shares an identical value within the attribute table. Figure 37 shows that all 

polygons containing a common attribute are merged. For example, this tool is used when a layer 

of districts is required to obtain a layer of regions. However, in this case the table associated 

with the districts must have a field indicating the region to which each district belongs. To open 

the Dissolve tool, go to:  

ArcToolbox > Data Management Tools > Generalization > Dissolve 

In the pop-up window of the Dissolve tool you must configure the parameters as follows: 

- Input Features: Select the layer of points, lines or polygons on which to work. 

- Output Features Class: Select the directory or geodatabase where the resulting file will 

be stored. 

- Dissolve Field:  Select the field containing the attributes according to which the entities 

will merge. 

- Statistics Field: This allows statistical calculations of the fields to be dissolved.  
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Figure 37. Dissolving entities 

10. Spatial analyst  

Spatial analysis is the process of modeling and obtaining results through computer processing 

and then examining and interpreting the results of the model. Spatial analysis is useful for 

assessing suitability and capacity, for calculating and predicting, and for interpreting and 

understanding spatial phenomena (ESRI, 2016b). 

A license from the Spatial Analyst extension is required to run the tools used in this section. 

10.1. Interpolations 

Tobler’s first geography law (1970) states: "Everything is related to everything else, but near 

things are more related than distant things. For example, if it rains on one side of a street, it is 

highly likely to rain on the other side of the street as well”. 

According to Gruver & Dutton (2014) interpolation is a process that uses measurements made 

on some phenomenon (precipitation, temperature, elevation) in certain places (samples or 

stations) to make a prediction for the same phenomenon in places where no measurements 

have been made.  

There are many methods of interpolation, some of which have a greater presence in GIS because 

they are more adapted to the type of data handled. The usual application within a GIS is two-

dimensional, since a raster layer is such an entity. We are therefore talking about spatial 

interpolation. However, these methods are not only restricted to a plane, but can be extended 

to a larger number of dimensions to reflect other variables such as depth (e. g., to construct a 

three-dimensional model of soil characteristics between two established depths and at a given 

interval), or time (Olaya, 2014). 
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The interpolation techniques mentioned by Childs (2004) are deterministic and geostatistical. 

The deterministic interpolation technique creates surfaces based on measured points or 

mathematical functions. Methods such as Inverse Distance Weighting (IDW) are based on the 

degree of similarity of cells, while methods such as Trend are adapted to a smooth surface 

determined by a mathematical function. The geostatistical interpolation technique, Kriging, is 

statistics based and is used for the most advanced prediction of surface modeling, which also 

includes some degree of prediction certainty or accuracy. There are different classifications of 

interpolation methods, some of which can be consulted in Olaya (2014). 

Without going into more detail on the various methods of interpolation, all of these are available 

at the following address:   

ArcToolbox > Spatial Analyst Tools > Interpolation 

Table 3 contains precipitation data from weather stations located at different points. The central 

idea is to construct a raster surface with estimated precipitation values for places where there 

are no weather stations.  

Table 3. Monthly precipitation and temperature data from a network of meteorological 

stations 

Station UTM_X UTM_Y UTM_Z Precipitation (mm) Temperature (°C) 

A 694294 9558872 2377 89.4 13.13 

B 697901 9563240 2033 40.2 15.51 

C 700975 9560679 2218 53.1 14.23 

D 694716 9555060 2816 75.9 11.17 

E 692138 9559012 2952 72.8 11.07 

F 706230 9560170 2850 102.4 10.34 

G 699711 9553629 2160 72.5 14.59 

 

However, to interpolate the data it is necessary to have a shapefile or vector layer of points. If 

the point layer does not exist, XY coordinates can be imported and transformed into a shapefile. 

ArcGIS supports different table formats such as Excel 97-2003 files, tab delimited text, DBF, and 

CSV. 
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Practice: Add XY coordinates and export them as shapefile. 

In a new ArcMap window, from the menu bar go to File > Add Data > Add XY Data. In the pop-

up window that appears, you should set up the fields as follows:  

- Choose a table from the map or browse for another table: Select the table containing 

precipitation data. Information from Table 3 is stored as an XLS file (Excel Book 97-2003).  

- X Field: Select the field containing the longitude values (UTM_X).  

- Y Field: Select the field containing the latitude values (UTM_Y). 

- Z Field: This is optional, but you can select the field containing the altitude values 

(UTM_Z).  

- Coordinate System of Input Coordinates: With the Edit button, select the coordinate 

system, in this case Projected Coordinate Systems > UTM > WGS 1984 > Southern 

Hemisphere > WGS 1984 UTM Zone 17S. 

This process generates an event layer; however, to store this layer on the hard disk in shapefile 

format, it is necessary to follow the following steps: Right click on the layer in the table of 

contents and go to Data > Export Data. A pop-up window opens where the address and name 

of the file to be saved must be selected. If you do not save the file in shapefile format, you must 

verify that the format type has been selected correctly (in Save as type). This step is necessary 

for the information to be stored in a shapefile. 

Of the various interpolation options allowed by ArcGIS, the method used here to interpolate 

precipitation is Kriging, which is located at the following address:  

ArcToolbox > Spatial Analyst Tools > Interpolation > Kriging 

The speed of execution of the process depends on the number of points to be processed and 

the available system resources. The configuration pop-up window in all interpolation tools looks 

similar. An example of the parameters required by the tool, in this case Kriging (Figure 38), is 

described below:  

- Input point features: Select the point layer containing the precipitation values (e. g. 

shapefile created from Table 3). 

- Z value field: Select the field that stores the precipitation values. 

- Output surface raster: Select a directory or geodatabase to store the output raster file. 
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- Semivariogram properties: Allows you to select the Kriging interpolation method with 

its respective semivariogram model. 

- Output cell size: Sets the cell size (resolution of the resulting map). 

- Search radius: Sets the radius of the entry points to interpolate each cell. 

- Output variance of prediction raster: This is an optional raster containing the 

semivariance values. 

 

Figure 38. Configuration of Kriging tool parameters 

Figure 39 shows the results of interpolation on a raster surface with estimated values. On the 

left, you can see the points where the weather stations are located (converted to shapefile 

format). On the right, you can see the map resulting from the interpolation as a raster image, 

including the estimated precipitation values for each cell. The same process can be repeated to 

obtain a temperature raster image using the values in Table 3. 
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Figure 39. Rainfall interpolation.  Weather station points (left) and interpolated prediction surface (right). 

10.2. Digital elevation models 

A Digital Elevation Model (DEM) is a raster representation of a continuous surface. It usually 

refers to the earth's surface, using a set of points whose X, Y and Z values are known and defined 

in an arbitrary coordinate system (Fallas, 2007). 

The information that can be derived from digital elevation models can be applied in different 

fields, such as hydrology, risk analysis, urban planning, among others. The main products that 

can be obtained from a DEM are slope maps, contours, relief maps, visibility maps, aspect maps, 

watersheds, viewshed, etc. 

 

Figure 40. Digital Elevation Model 

10.3. Creation of slope maps  

Slope is the main factor that determines and differentiates the shapes of the relief. Given two 

points of different altitudes, the slope of the terrain is understood to be the mathematical ratio 

determined by the proportional relationship between the difference in altitudes and the 

horizontal distance between the two points (Hernández, 1998).  
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The slope can be expressed in percent or sexagesimal degrees. To create a slope raster, a DEM 

is required as input information, and the Slope tool is used to generate the slope raster, which 

is located at: 

ArcToolbox > Spatial Analyst Tools > Surface > Slope 

 

Figure 41. Configuration of Slope tool parameters 

The Slope tool configuration (Figure 41) is described as follows:  

- Input raster: Select the layer containing a DEM. 

- Output raster: Select a directory or geodatabase to store the slope raster file. 

- Output measurement: Select "DEGREE" for decimal degrees, and "PERCENT_RISE" for 

percentage. 

- Z factor: This is an optional factor, used to match Z linear units to XY linear units. 

 

Figure 42. Raster of slopes in degrees 
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10.4. Reclassifications  

The Reclassify tool allows the values of a raster to be reclassified; that is, it replaces the current 

values of each cell with new information. Data can be reclassified from any variable stored in 

raster format (slope, elevation, precipitation, temperature, etc.). 

Practice: Build a slope map based on the classification proposed by FAO (2009) and group the 

values of the slope raster into classes (e. g. Figure 42). Table 4 presents eight classes, each of 

which contains the slope values in percent and decimal degrees. 

Table 4. Slope gradient classes 

Class* Description Percentage  Degrees 

01 Flat 0 - 1 0 - 0.57 

02 Very slightly sloping 1 - 2 0.57 - 1.15 

03 Slightly sloping 2 - 5 1.15 - 2.86 

04 Inclined 5 -10 2.86 - 5.71 

05 Strongly sloping 10 - 15 5.71 - 8.53 

06 Moderately steep 15 - 30 8.53 - 16.70 

07 Steep 30 - 60 16.70 - 30.96 

08 Very steep > 60 > 30.96 

* Class 01 is a consolidation of the first three gradient classes of (FAO, 2009).  

To run the reclassification, open the Reclassify tool at the following address: 

ArcToolbox > Spatial Analyst Tools > Reclass > Reclassify 
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Figure 43. Configuration of parameters of the Reclassify tool 

In the pop-up window, the parameters described below (Figure 43) must be configured: 

- Input raster: Select the layer containing the slope raster. 

- Reclass Field: Select the field containing the slope values. By default, this is usually 

VALUE. 

- Reclassification: Within this section clicking on the Classify button opens a sorting 

window where class values can be adjusted. In the Classification section of the 

classification window you can select the classification method and define the number of 

classes (8). In the lower right-hand corner of the Break Values section, you can manually 

enter the limits of each class (e. g. gradient values as a percentage of Table 4). 

- Output raster: Select a directory or geodatabase to store the reclassified slope raster 

file. 
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Figure 44. Raster of reclassified slopes  

10.5. Contour creation 

Contours are lines connecting points of equal value that represent continuous phenomena 

(Huisman & A. de By, 2009). Contours are called isolines, but may also have specific terms 

depending on the phenomenon. These are called contour lines (Figure 45) when used to 

represent elevation, isobars for atmospheric pressure, isohyet for precipitation, isotherms for 

temperature and isochrons for time (Olaya, 2014).  

 

Figure 45. Contour lines (m.a.s.l.) 

The process for generating isolines of all kinds is similar. If you need to create contours, you 

need a DEM as input information. The isolines are generated with the Contour tool, located at:  
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ArcToolbox > Spatial Analyst Tools > Surface  

 

Figure 46. Configuration of the Contour tool parameters 

The settings of the Contour tool parameters (Figure 46) are detailed below:  

- Input raster: Select the raster containing the values (to generate contour lines a DEM 

raster is required, isohyets a precipitation raster, for isotherms a temperature raster). 

- Output polyline features: Select the directory or geodatabase to store the line layer 

(level curves). 

- Contour interval: Define the interval between isolines. It is important to take into 

account the resolution of the raster; for example, if the DEM has a resolution of 30 

meters, it is not recommended to create contours of less than 30 meters. 

- Base contour: Optionally, a base level value can be assigned. 

- Z factor: Optionally, a conversion factor can be assigned to generate the isolines. This is 

used to perform unit conversions (e.g. meters to feet). 

10.6. Map algebra  

The raster layer calculator (or simply raster calculator) is created to run algebraic expressions 

using various tools and operators through the interface of a simple calculator tool (Raster 

Calculator tool). The performance of equations depends on the tools or operators involved in 

an expression. In general, data processing is faster if each operator or tool is executed 

individually (ESRI, 2016c). The versatility of the map algebra lies in its simplicity and power to 

perform geographical analysis. 
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A raster layer can be created from an algorithm by assigning numerical values to the pixels that 

compose it or it can be derived from one or more previously existing raster layers. A simple 

example is shown in Figure 47. On the left-hand side you can see the initial raster map, in which 

you want to execute a simple operation consisting of multiplying all the pixels of the layer with 

by factor 5. The result is stored in a new raster layer (Figure 47 right).  

 

Figure 47. Basic map algebra operation 

Practice: From the data in Table 3, you can create a raster image by interpolating the 

temperature values (see Figure 49, left), following the steps in section 10.1. The idea of this 

exercise is to familiarize yourself with the use of algebraic expressions using the Raster 

Calculator tool. The temperature raster layer is generated in Celsius Degrees, but if we want to 

convert the values to Fahrenheit (see Figure 49 right), the following equation must be applied 

within the raster image calculator:  

𝐹 = (𝐶 ∗  
9

5
) + 32 

where: 

F = Temperature in degrees Fahrenheit 
C = Temperature in degrees Celsius 

The Raster Calculator tool for running algebra map expressions is located at: 

ArcToolbox > Spatial Analyst Tools > Map Algebra > Raster Calculator 
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Figure 48. Configuration of expressions in Raster Calculator 

The configuration of the Raster Calculator tool (Figure 48) is as follows: 

- Layers and variables: Displays a list of layers available for use in the map algebra 

expression. 

- Operators: Allows you to enter mathematical and logical operations in the expression. 

Click on the calculator button to enter the number or operator into the expression. 

- Tools: Displays a list of tools (sine, cosine, tangent) to use anywhere in the expression. 

- Expression: This allows you to create a set of rules to execute a valid statement. It is not 

necessary to place the sign "equal" (=) at the beginning of the expression. In the 

equation for converting degrees Celsius to Fahrenheit, replace “C” with the raster image 

name: “T_°C” * 9 / 5 + 32. Use parentheses to group algebraic expressions, if needed.  

- Output raster: Select a directory or geodatabase to store the raster file generated by 

the resulting expression. 

Operators 

 

Tools 

 

Expression 
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Figure 49. Temperature raster in °C (left). Temperature raster in °F obtained through a map algebra expression 

(right). 

10.7. Topographic profiles 

A topographic or elevation profile is a two-dimensional cross-section of the terrain. It is a side 

view of the terrain represented by a line drawn between two or more points on a map. The Y 

axis corresponds to the altitude or elevation values, while the X axis corresponds to the values 

of the distance between these points.  

Creating a topographic profile can be easy, but creating an attractive and elegant graphic is a 

laborious task. In ArcMap you can generate simple graphics, but with the help of Microsoft Excel 

you can considerably improve the final design of the graphic. 

Practice: Create a topographic profile of several points corresponding to populated sites. The 

main activities to be developed in this practice are: 

▪ Create a Profile Graph and Point Profile in ArcMap. 

▪ Export the created profile table to Excel. 

▪ Create a scatter plot (XY) with the two sets of data (Profile Graph and Point Profile) in Excel. 

▪ Add labels, and fine-tune details and graphic design with formatting options in Excel. 

The first step is to add a DEM and a layer of points inside ArcMap (Figure 50). The points layer 

corresponds to villages that exist in the area.  
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Figure 50. Digital Elevation Model (DEM) with one layer of points 

If the points are only in 2D (XY coordinates), it is necessary to convert these vector points into 

3D to obtain the Z (height) values of the points. For this, a DEM is required, from which altitudinal 

information can be extracted for each point. You should address it to: 

ArcToolbox > 3D Analyst Tools > Functional Surface > Add Surface Information 

 

Figure 51. Configuration of the Add Surface Information tool 

The "Add Surface Information" window, shown in Figure 51, must be configured as follows:  

- Input Feature Class: Enter the point layer (Profile_points). 
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- Input Surface: Enter the digital elevation model (Loja17S.img). 

- Output Property: Check the Z box. 

Click on "OK" and then by opening the attribute table of the point layer you can see the Z values 

in a new field. To convert points from 2D to 3D you should go to the following address: 

ArcToolbox > 3D Analyst Tools > 3D Features > Feature To 3D By Attribute 

 
Figure 52. Feature To 3D By Attribute tool configuration 

The Feature To 3D By Attribute tool window (Figure 52) must be set up as follows:  

- Input Features: Enter the point layer (Profile_points). 

- Output Feature Class: Assign a name to the output layer (Profile_points_3D). 

- Height Field: Select the field containing the Z values. 

Once the plot layer is set up, you can create a profile graph based on the points. In order to 

generate the Profile Graph, you must perform the following steps: 

- First make sure to activate the 3D Analyst toolbar (Customize menu > Toolbars). Then, 

click the Interpolate line ( ) icon.  

- With this tool you can freely draw the line of the topographic profile. To create this line 

it is very important to take into consideration the direction (from left to right or vice 

versa) because the Profile Graph tool will be plotted according to the direction of the 

starting point. In this example it was used in a left-to-right direction. 
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- Once the profile line has been created, click the Profile Graph ( ) button on the 3D 

Analyst toolbar. Here, a profile graphic should appear as shown in Figure 53. 

 

Figure 53. Creation of an elevation profile with the Profile Graph tool 

Now you need to create a new graph using the plot layer. To do this, you must carry out the 

following steps: 

- On the 3D Analyst toolbar click on the Point Profile ( ) icon.  

- Draw a new line with the same length and direction as the first red line (best to be 

accurate, but no problem if you can't get a line exactly the same as the first). It is 

recommended to click first at the beginning of the first line (red), with the second click 

at the end of the line. Then, move the mouse pointer up or down by drawing an area 

that includes all the desired points (black box). Finally, a third click is made to create the 

Point Profile. We recommend looking at Figure 54. 
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Figure 54. Creating an elevation profile with the Point Profile tool 

We have already created elevation profiles in ArcMap. However, in order to improve the 

presentation with a more attractive and elegant design, the data should be exported to 

Microsoft Excel. This is done in the following way: 

- From ArcMap, right click on the first Profile Graph > Advanced properties. 

- In the new window, click Data, then click on the Copy ( ) button (see Figure 55).  

- Once in Excel, you must paste the data into a new book. 

- Then, repeat the process with the second point profile graph. 

 

Figure 55. Advanced profile graph options 
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Once the data for both profiles are found within Excel, the point labels must be added (Figure 

56). In our example, these are city names. Several options exist to obtain the labels on our chart; 

for example:  

- The names can be typed manually in a new Excel column. 

- Labels can be obtained by directly opening the *. dbf file in Excel, and copying these 

names into a new column. 

 

Figure 56. Data of elevation profiles within Excel 

To improve the appearance of the profile graphic, it is necessary to prepare the data. Two steps 

are sufficient: transform the X values, which are the length scale, from meters to kilometers, 

and smooth the Y data of the elevation line as follows: 

- First, the length values must be transformed from meters to kilometers. This is very 

easy, and you can do it in a new column by dividing the values of X by one thousand. For 

example. In cell D2 type: =B2/1000. The same is true for Point Profile length values, in a 

new column you can type: =H2/1000 (See in Figure 57 the columns D and I).  

- Second, the profile line must be smoothed, based on the data. This is basically to show 

the most important patterns or trend of the profile line by removing the finer details. In 

other words, we obtain a smoothed line of the elevation profile. There are many 

methods to accomplish this task, but in our example we use a simple method by 

calculating simple moving averages in Excel. However, remember that you can use any 

other technique. Subsequently, consecutive averages are calculated in sets of 100 rows 

(or another number of rows according to the degree of smoothing desired). The rows 

can be changed depending on the length of the elevation profile, or according to the 

required smoothing force. For example. In an empty column, in the first row (E2), you 

can use this formula: =AVERAGE(C2:C101), then drag to all cells of the column (see 

Figure 57). 
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Figure 57. Data smoothing in Microsoft Excel 

For plotting Excel graphics, insert a new scatter diagram (X, Y): 

- Select two columns: Length (as X axis) and Elevation (as Y axis). In our example, columns 

D and E are used. 

- Go to the Insert menu > Charts > Scatter with Smooth Lines. The line of the smoothed 

profile is shown in Figure 58.  

 

Figure 58. Plotting scatter plots in Microsoft Excel 

To add a new series containing the points with their locations within the same graphic, you must 

do the following: 

- Right click on the graphic > Select Data... 

- Click on Add. 

- Put a new name under Series Names: (In this case "Sites"). 

- Under "Series X Values:" select the X values of the second graph (In this case the column 

"Length2 (Km)" =Sheet1!$I$2:$I$11). 
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- Under "Series Y Values:" select the Y values from the second graphic (In this case the 

column "Point Profile" =Sheet1!$J$2:$J$11). 

- A second line is added to the chart (Figure 59), but not yet ready. 

 

Figure 59. Dispersion graph that includes two series 

The graph of the second line (Sites) must be changed to points by means of the indications 

shown in Figure 60: 

- Select the newly added line (orange). 

- Right-click select Change Series Graph Type... 

- Click on the name of the second series (Sites). 

- Click on the drop-down menu. 

- Click on the type of graphic called "Scatter" 

 

Figure 60. Change of chart type, from lines to points 
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The elevation profile is almost ready, but the point names are not yet displayed. To add the 

labels, the following actions must be carried out (Figure 61): 

- Select the point series ("Sites"). 

- Go to the “Design” menu > Add Chart Element> Data Labels > More Data Label Options... 

- Select “Value From Cells” from the right panel in the label options. 

- Select the column containing the labels (=Sheet1!$K$2:$K$11). 

- Deactivate the "Y Value" checkbox. 

 

Figure 61. Add labels to point information 

Finally, after a laborious process the topographic profile or elevation profile is ready, including all the points and 

their locations (Figure 62. Topographic or elevation profile. 

).  Additionally, you can further improve the graph by customizing the following features:  

- Title and legend. 

- Text color and size. 

- Axis titles. 

- You can also customize the profile line with a color gradient (as in our example, the 

profile line goes from orange to green). 

- Remove internal dividing lines, scale adjustment, etc. 
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Figure 62. Topographic or elevation profile. 

11. Design and publication 

Mapping can be a laborious process until you get the right result. Viewing data to analyze and 

interpret spatial information on a computer is one thing, but printing a map for others to analyze 

and interpret is quite different. ArcMap makes available a number of tools for map design prior 

to publication (Hillier, 2011). In general, the simpler a map is, the easier it is to understand. This 

means avoiding unnecessary content, selecting appropriate colors, selecting the correct text size 

and prioritizing information according to its relevance. In other words, it is not just a matter of 

creating a map that is pleasing to the eye, but one that can convey the purpose for which it was 

designed.  

A map is an incomplete representation or perception of the territory. The map offers the public 

only what the cartographer wants to show. The designer selects in a reasoned way the elements 

he wishes to map, but his choice depends on his own knowledge, sensitivity and intentions 

(Rekacewicz, 2006). 

11.1. Symbology of points, lines and polygons.  

Symbology allows you to define how each element will be displayed on the map (symbols, colors, 

frames, text). It must be decided whether or not it is required to display the information 

according to the attribute table of each layer. 
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To configure the symbology of the layers created in section 7.1, right click on the layer to be 

customized (buildings), select Properties, and click on the Symbology tab.  

 

Figure 63. Symbology tab of a layer properties 

On the Symbology tab, to represent geographic information, the following aspects must be 

considered for its configuration:  

- Show: This is on the left-hand side of the window. It allows information to be organized 

individually, by categories, numbers, graphs and multiple attributes. For the building 

layer, select Categories > Unique values.  

- Valued Field: Select the Type field to represent in categories the information stored 

within the same field. Clicking Add All Values adds all categories, clicking Add Values 

adds categories individually, Remove deletes the selected category and Remove All 

deletes all added categories.  

- Color Ramp: A default color palette can be selected. 

When you add all the categories of a layer, by default, <all other values> are added, it is 

recommended to uncheck the box. You can also remove the tag (Type) from the <Heading> 

header (see Figure 63). To see the changes in the table of contents click Apply and to accept 

them click OK. It is recommended to arrange the layers according to their geometry within the 

table of contents.  
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The same procedure can be applied to the road_network and plant_cover layers to add all their 

categories based on the information contained in the attribute table.  

 

Figure 64. Configuration of the Table of Contents 

In the table of contents, the List By Drawing Order ( ) button must be enabled to drag and 

drop layers in the required order (e. g. polygon at the bottom, lines in the middle and finally 

points on top). 

By default each layer has exactly the same file name (Figure 64 left) and each category has the 

name according to the attribute table (Figure 64 center). To edit the name of a layer or category, 

click on it and you can change it individually.  It is important to check that everything is written 

correctly (Figure 64 right), because the map legend will show those names.  

When a layer is first loaded into ArcMap it is assigned symbols of the same size, shape and color 

(Single Symbol). In order to represent the real world through a map, it is necessary to use 

appropriate symbols that can properly represent the nature of the information.  

ArcMap contains an extensive library of symbols used in various disciplines. The symbol that 

conveys what really needs to be represented must be carefully chosen. The symbol for each 

point in the list can be sorted individually. For example, to customize the School symbol (from 

the Buildings points layer) you must perform the following steps (Figure 65): 
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- Double click on the layer (or directly in the symbol). 

- Double click on the symbol in the list. 

- In the Symbol Selector window, click the Style Reference button.  

- Check the Civic checkbox (or the required symbol libraries).  

- In Symbol Selector select the School 1 symbol. 

- In the Color button select the black color from the drop-down list (to customize click 

More Colors, in the Color Selector window you can customize RGB values).  

- Select the size of the points layer symbol in the Size button. For lines, select Width for 

the line width, for polygons select Outline Width for the contour line width, and select 

Outline Color for the color of the contour line.  

 

Figure 65. ArcMap symbol library 

For the remaining layers, assign the symbology according to Table 5 based on the process 

described in the previous paragraph.  
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Table 5. Definition of symbol properties 

Shapefile Categories Symbol RGB color 
Symbol size 

or line width 

buildings School  

Hospital 

Church  

House 

School 1 

Hospital 1 

Place of Worship 1 

Building 1 

0,0,0 

255,255,255 

0,0,0 

255,255,255 

18 

14 

18 

8 

hydrant_points Hydrant points Faucet 0,0,0 18 

secure_sites Secure sites Rnd Square 1 0,0,0 14 

road_network Street 

Path 

Unpaved way 

Main way 

Road, Proposed 

Dashed 4:4 

Road, Unpaved 

Highway 

255,55,55 

0,0,0 

115,76,0 

250,52,17 

1 

0.40 

2 

1.70 

water_network Water network River 10,147,252 1 

plant_cover Forests 

Crops 

Grassland 

Scattered Trees 1 

Cropland 

Grassland 

109,187,67 

227,158,0 

109,187,67 

0.40 

0.40 

0.40 

lake Lagoon Lake 151,219,242 0.40 

 

11.2. Map design  

It is impossible to transpose the real world onto a map, so that anyone who picks up a map has 

no option but to believe in it. The cartographer is completely free to transcribe the world as he 

sees fit (Rekacewicz, 2006), but in depicting reality one should not bias or manipulate 

information, but maintain as impartial as possible.  

The distribution of the elements of a map is subject to the author's requirements. The important 

thing is that a map can be understood by the target audience. Figure 66 suggests the layout of 

the map elements - although not all elements are obligatory, at least it should contain the title, 

grid, geographic north, scale, and legend.  
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Figure 66. Elements to design a map 

Before you start with the map layout, it is recommended that you set the orientation and size 

of the paper. From the File menu, go to Page and Print Setup to select the printer. In the Paper 

> Size section, select the size (e. g. A4 paper) and orientation (Orientation > Landscape to 

orientate the sheet horizontally; select Portrait for vertical presentation.  

From the Customize > Toolbars menu, activate the Draw toolbar (Figure 67), because it contains 

tools for adding and editing graphic elements in the Layout.  

 

Figure 67. Draw toolbar 

To start designing the map, change the Data View screen to Layout View from the View menu, 

or using the buttons shown in Figure 1. It is important to note that what you see in the Layout 

View is how it will look when printing or exporting the map.   

The configuration of the elements in Figure 66 is as follows:  
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Title (1) 

From the Insert menu select Title, and in the dialog box set the title as: My first map in ArcGIS.  

Body of the map (2) 

The data frame is automatically displayed by default when you switch to the Layout View screen. 

The body of the map is the fundamental part of a map, which contains all the layers to be 

represented within a map. To reduce or enlarge the map body, click on the map rectangle and 

adjust the borders as required.  

Grid (3) 

To insert a grid in UTM coordinates, use the Grids and Graticules Wizard (see Figure 68), 

performing the following steps:  

- Go to the View menu. 

- Click on Data Frame Properties. 

- Go to the Grids tab. 

- Click on New Grid to open the wizard (click the Next button to complete the 

configuration in each window).  

- In the Grids and Graticules Wizard window, select Measured Grid to display the 

coordinate grids projected on the map.  Graticule: for crosshairs divided by longitude 

meridians and parallel meridians of latitude. Reference Grid generates a reference grid 

divided into rows and columns.  

- If Measured Grid is selected, the Create a measured grid window appears. In the 

Appearance section, select the shape and style of the grid. By default the Coordinate 

System section shows the coordinate system used in the current map, but it is possible 

to change it. In the Intervals section, the XY axis spacing is defined, in this case 100 

meters. 

- If Appearance is selected in the Grid and Labels option, the Axes and Labels window 

will appear where you can configure the Axes of the grid and line style. To customize the 

text style, click on Text style. When all parameters have been set, click Next.  

- Finally, the Create a measured grid window appears, in which you can configure the 

place of the borders in the grid. The Grid Properties section allows you to store the grid 

as a static or upgradeable graph in the event of changes in location and scale of the map.  
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Figure 68. Grids and Graticules Wizard steps in the order: Grids and Graticules Wizard, Create a measured grid, Axes 

and labels, and Create a measured grid. 

Usually when a projected coordinate grid is added, the axis labels show six decimal places (e. g., 

691900000000 9532700000000). In the properties of each grid, existing grids and reticles can be 

managed. To remove the remaining decimal places from the grid axes, follow these steps: 

- Go to the View menu. 

- Click on Data Frame Properties. 

- Go to the Grids tab. 

- Select the grid and click on Properties. 

- Go to the Labels tab. 

- Click on Additional Properties. 

- Click on Number Format. 

- In the Rounding section, leave the number of decimal places at zero. 

Geographic North (4) 

To indicate the orientation of the map, use the North arrow. From the Insert menu, select Insert 

North Arrow. Then place it on the required North 2 arrow symbol (ESRI North 2) and click OK to 

add. With the Selects Elements (  ) button on the Draw toolbar you can select the North arrow 

and resize it and move it freely over the map.  
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Location map (5) 

Knowing where the study area is located allows the map reader to be spatially orientated in a 

wider context. In ArcMap you can add location indicators to connect data frames (Data Frame). 

The location map can be added by considering the following steps: 

- Go to the Insert > Data Frame menu to add a new blank data frame.  

- Use the Select Elements button (  ; on the Draw toolbar) to adjust the size and 

position of the new data frame.  

- Add one or more layers to indicate the spatial extension greater than the study area 

using the Add Data button ( ; on the Standard toolbar). For example, if the study 

area is Ecuador, it would be convenient to add the South American layer.  

- Configures the symbology and design of the layers of the new data frame.  

- In the Table of Contents, right click on the New Data Frame and select Properties.  

- Go to the Extent Indicators tab (Figure 69). 

- From the Other data frames box add the Data Frame (Layers) to the Show extent 

indicator for these data frames box.  

- Optionally, you can configure the style of the Data Frame in the Options section (name 

of the Data Frame).  

- Insert a text box from the Insert > Text menu to add the title (for example: Location 

map).  

 

Figure 69. Configuration of location indicators 



67 
 

As many data frames as required can be inserted. Try not to use a study area that is too small in 

comparison with the area showing its location.  

To switch between each data frame ( ) in the table of contents, right click on Layers and select 

Activate. You can only manipulate the layers of a Data Frame when it is active.  

Legend (6) 

A legend allows the map reader to know the meaning of the symbols used to represent each 

element built into the map. To open the legend wizard, proceed as follows:  

- Go to the Insert menu and select Legend (to advance between windows, click Next). 

- In this window, in the Choose which layers you want to include in your legend section, 

from Map Layers you must pass the layers you want to show to Legend Items using the 

existing arrows. When there are several elements in the legend, you can choose to 

organize in columns in Set the number of columns in your legend. 

- In the next window, in Legend Title you must assign a title to the legend. The text can 

be customized at the bottom.  

- The following window in Legend Frame allows you to customize the border, background 

and shading of the legend. Styles should be combined carefully for an attractive design.  

- The following window allows you to change the size and shape of the symbols used to 

represent lines and polygons. Usually the default settings are left.  

- In the last window you can configure the spacing between each part of the legend. If 

everything has been configured successfully, click Finish.  

- Use the Select Elements button (  ; on the Draw toolbar) to adjust the size and 

position of the legend. 
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Figure 70. Start window of the legend wizard  

Numerical scale (7) 

The numeric scale shows the relationship between the length values shown on the map and the 

actual length values of the terrain. Before inserting the numeric scale into the map, specify the 

scale value (3000) on the Map Scale in the Standard toolbar (Figure 5).  

To do this, go to the Insert menu and click on Scale Text. From the list of various numerical scale 

formats select Absolute Scale and click OK. It can be verified that the denominator of the 

generated numeric scale is dynamic: when modifying the scale of the map the denominator of 

the scale is automatically modified. 

The Select Elements button ( ) can be used to adjust the position of the map. In addition, you 

must also go to the Insert > Text menu to add a text box. Write the word "Scale:". Use the Select 

Elements button to set the text box in front of the numeric scale. So that you can read: "Scale 

1:3.000"  

Graphic scale (8) 

The graphic scale is a bar divided into parts that visually indicates the length on the ground. To 

add a graphic scale, go to the Insert menu and select Scale Bar. From the list of scale bars you 
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can select the preferred scale (e. g. Alternating Scale Bar 1). Use the Select Elements button (

)  to adjust the position.  

To configure the graphical scale, the following aspects must be taken into account: 

- Click the Select Elements button ( ) to right click on the graphic scale and select 

Properties.  

- Go to the Scale and Units tab.  

- In the Units section select meters as the division unit. In Label write: Meters.  

- In the Scale section, in When resizing select Adjust width. Insert the value 2 in Number 

of divisions and Number of subdivisions; in Division value insert 50 (the length of the 

graphic scale is obtained by multiplying the values of Division value and Number of 

divisions).  

 

Figure 71. Graphic scale configuration 

Geodetic reference parameters (9) 

It is always necessary to specify the geodetic reference system used in mapping. To do this, go 

to the Insert > Text menu and type the following text:   

Universal Transverse of Mercator Projection.  
Elipsoid and Horizontal Datum WGS 84 Zone 17 South. 
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Area of cards or boxes (10) 

The cards or boxes allow you to add information to the map. You can include the names of those 

responsible for its elaboration, the name of the project or program, logos, the source of the 

cartographic inputs, date of elaboration, working scale, etc. 

To add a logo, go to the Insert > Picture menu. Browse and select the image to use. Adjust the 

size and position with the Select Elements button ( ).  

In addition, you can build an information box with ArcMap drawing tools.  But it is recommended 

to insert it as an object. To do this, go to the menu Insert > Object > Microsoft Word Document. 

In the Word document that opens, as an example, you can copy Table 6, then close Word. Finally, 

the size and position is adjusted with the Select Elements button ( ).  

Table 6. Information card 

Information box 

Communal base map 

Topic: My first map in ArcGIS 

Source: Ortofoto Programa SIG Tierras Date: February 2018 

When you have entered all the elements to be published on the map, it is recommended to 

organize each one of the elements to improve the visual presentation. For example, selecting 

multiple items and right-clicking on them displays options for grouping, aligning, distributing, 

and so on. 

11.3. Export and print a map 

Once the mapping process is complete, a map can be printed or exported in various formats. 

To print the map, go to File > Print menu, and configure the printer according to the features 

you have. 

If you need the map to be in another digital format, it is exported from the File > Export Map 

menu. Select between EMF, EPS, AI, PDF, SVG, BMP, JPEG, PNG, TIFF, and GIF formats. The 

resolution and additional parameters can be configured in each format.  

In some cases, especially when special characters are available, a PDF file is not usually readable. 

We recommend using a PDF printer that is installed in the system. 
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Finally, you can see the result of the map prepared following the instructions in this document 

(Figure 72). 

 

Figure 72. Example of a map elaborated with ArcGIS 10 

12. Frequently asked questions 

Which zone do I select if my study area shares two UTM zones? 

What you usually do in this case is work with the UTM zone that contains most of the study area.  

If I copy an MXD project, will all the map layers (shapefiles and images) be copied? 

No, an MXD file simply manages file paths and displays settings for legends, display scales, case 

selection, etc., among other things, but not the layers themselves. Before starting a project, it is 

recommended to store all layers within a single directory. In the File > Map Document 

Properties menu, select the Store relative pathnames to data sources check box to make it 

easier to connect files linked to the MXD.  
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You can also package a map project and all associated layers. To do this, go to the File > Share 

As menu to create a Map Package. The reader is allowed to investigate the uses (and drawbacks) 

of this tool.  

How do I put labels on a layer? 

Labels allow you to display the information of the elements that make up a layer: for example, 

if you want to display values for a layer of contour lines, hospital names in a point layer, the 

name of national parks in a polygon layer.  

To add labels right click on a layer and select Properties. Go to the Labels tab and select the 

Label features in this layer check box. In the Text String section in Label Field select the field 

containing the information to be displayed on the map.  

Although in the Label tab you can configure the style, positioning and other options for labels, 

for greater personalization you can change the tagging engine from the View > Data Frame 

Properties > General Tab > Label Engine > Maplex Label Engine menu.  

What are the main elements that a map should have? 

This depends on many factors, among others: the map’s audience, size of the paper to be 

printed, distance from which it will be visualized, etc. Assuming that we are preparing a map for 

an academic work or consultancy, from our point of view the elements that will always be 

necessary are the graphic/text scale, the legend (s), the grid of coordinates and the north. If the 

map is presented on a separate page, it is highly recommended to use boxes, where the title of 

the map, the authors, the institution where it was made and the date will be indicated; for 

example, if the map is part of a text document and is to be inserted in the same, the title of the 

map must be in the figure footer.  

What is the difference between projection and datum? 

In simple terms, projection is the method used to represent the curvature of the earth on a flat 

surface, and datum is the set of parameters that are used to do it. 

Is it possible to create several layouts in ArcMap? 

No, you can only create one per map project (one for each MXD). 



73 
 

Can I insert a grid of flat coordinates and a grid of geographical coordinates? 

Yes, it can be done. In the Data Frame properties, go to the Grids tab > New Grid.  You can add 

multiple grid coordinates.  

Why don’t my data have a reference system? 

This problem is very common in GIS.  It is possible that the person who created the data did not 

define the spatial reference system used. Nor can one guess the reference system used if there 

is no record. In shapefiles the reference file has a PRJ extension. 

Can I import CAD files into ArcGIS? 

Yes. Let's assume we have an AutoCAD (DWG) file that is storing a topographic map. Click on 

Add Data and locate the AutoCAD file. Double-click on it and a list of files, which are actually the 

types of geometries contained in the AutoCAD file, appears.  Now let's assume that we want to 

export the contours from the AutoCAD file. The contours are always polylines, so choose 

Polyline and click on Add. With this we have uploaded all the polylines of the AutoCAD file into 

ArcMap. Since we only want to export the contours (we will assume that these are in layer 27), 

we have to tell ArcMap that we only want to visualize this layer. To do this, go to Layer 

Properties and click on the Drawing Layers tab; this deactivates all layers and activates only the 

layer of the contours. When only the contour lines are visible, we can export the layer to any 

vector format (Data > Export Data). 

Can I add new symbols to ArcGIS? 

Yes. New symbols can be inserted in the style manager. Go to the Customize > Style Manager 

menu. Go to the Windows local user style file. Choose a category and right click on New. 

Is it possible to convert a slope map from degrees to percent? 

Yes. It can be done with Raster Calculator. The formula is: 

s[%]=tang(s[°])*100 

where s[%] is the slope in percent and s[°] is the slope in degrees. 
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Can I import a shapefile table into Microsoft Excel? 

Yes, at least in the old versions of Excel, and also in Excel 2016. You have to open the program 

and tell it that you want to open a file. In the file type, indicate dBase (*.dbf). With LibreOffice 

you can do it, too. But be careful - the fact that it can be done does not mean that it is advisable. 

In fact, it is not advisable, because if you do something unexpected, like delete a column or even 

delete a row, the shapefile may be damaged and become unusable. We recommend you to copy 

only the DBF file to another directory and then open it and modify it as you want.  Any 

modification of the database associated with a shapefile is recommended to be done in a GIS. 

Can I convert a point shapefile to polygons? 

It’s possible, but the outcome may not be what you expect. To put it simply: from, say, 100 

points, and without violating the topologic rules, you can form a number of different polygons. 

On the other hand, there is a tool that generates a single polygon from a layer of points. It’s 

called Minimum Bounding Geometry and can be found in ArcToolbox, under Data Managemet 

Tools > Features. Its use is very intuitive.   

Why does ArcGIS usually close unexpectedly? 

ArcGIS applications sometimes close unexpectedly for no reason. When you agree to submit the 

bug report, it is sent directly to the Esri developer team. Some bugs are usually corrected by 

installing the Service Pack for each version. 

When I export a map to PDF, why not all the symbols are properly displayed? 

Usually, when special characters are used when exporting a map in PDF format, not all 

characters are displayed. It is recommended to export in PDF format from File > Print using a 

local PDF printer. 

How can I view the Table of Contents if I have closed it? 

Sometimes we accidentally close the Table of Contents. We go crazy for a while because we 

think it's a toolbar and try to activate it where toolbars are activated. However, to reactivate the 

table of contents, go to the Windows menu > Table of Contents. 

 



75 
 

Is it possible to calculate the centroid of a polygon? 

Of course. This is very easily done with the Feature To Point tool in ArcToolbox > Data 

Management Tools > Features. The operation of this tool is very simple. Just remember one 

thing: if you activate the "Inside (optional)" checkbox, all the points will fall within their 

respective polygons, but these points will not always be the centroids of the polygons in the 

strict sense of the word centroid. 

Why are the layers of my project displaced?  

It is quite possible that the layers have different spatial reference systems. It is also likely that 

the scale of work and inputs were different at the time of generating the layers. 

How can I know the resolution of a raster? 

Click twice on the layer, go to the Source tab and in the Property table you search for the Cell 

Size (X, Y) row (in my version it is the third one). Be careful! Don’t get confused: in this field 

there are two data, the resolution in X and the resolution in Y. So if you see 3,3, it doesn't mean 

that the spatial resolution of the layer is three point three meters, but rather that the resolution 

in X is three meters and the resolution in Y is three meters. GIS can theoretically handle raster 

layers of different resolutions in X and Y, although this layer type is very rare. To the best of the 

authors' knowledge, only some GIS like GRASS or R can handle these situations properly. 

Is the pixel size equal to the cell size? 

Yes, the pixel size is the cell size or spatial resolution of a raster. According to (ESRI, 2016d) a cell 

must be small enough to capture the necessary detail and large enough to run analysis tasks and 

efficiently store the information. The smaller the pixel size, the higher the raster resolution and 

the file size.  

How can I copy a shapefile to another computer? 

You can easily use ArcCatalog. This program has similar features to Windows Explorer, but with 

GIS layers, so it is very easy to copy, cut and paste GIS layers, including shapefiles. If you want to 

do it with Windows Explorer and, for example, you want to copy the layer "road_network.shp", 

make sure to copy all the files that are in that directory and whose names start with 
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"road_network" because, as you know, a shapefile layer is composed of several files, at least 

three and in most cases six. 

Can I open an MXD in a previous version of ArcMap? 

Not in principle. What you can do is save the MXD as a project file from an earlier version of 

ArcMap. This can be done from File > Save A Copy and in Type you choose the version of ArcMap 

for which you want the project file to work. Remember that the higher versions open the project 

files of the lower ones, but not vice versa.  

Do I have problems running an ArcToolbox tool? 

If opening an ArcToolbox tool gives a message similar to this "Unable to execute the selected 

tool. You do not have the necessary license to execute the selected tool ", you must be sure that 

you have a license for the extension you want to use. To activate an extension, go to Customize 

> Extensions menu. Extensions are only activated if you have a license. 

In some cases when you try to open an ArcToolbox tool, it sends the message "Do you want to 

open or save this file?" with reference to the MdDlgContent.htm file. To fix this error, Microsoft 

Windows Programs must be selected as the default in Windows settings.  

Why can’t I select A1 in the print size? 

The default paper size available in ArcMap depends on the printer options installed. If a printer 

only supports A4, it is not possible to select a larger size. To select any paper size in the print 

window (File > Print) uncheck the Use Print Paper Settings check box. 
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